Reactor Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 3
Number of dependencies (NOD): 63
Number of unique artifacts (NOA): 78
Number of version-conflicting artifacts (NOC): 14
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 80 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in modules

com.amazonaws:aws-java-sdk-core

[Error]
1.11.398
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.amazonaws:aws-xray-recorder-sdk-aws-sdk:jar:2.0.1:compile
       \- com.amazonaws:aws-xray-recorder-sdk-core:jar:2.0.1:compile
          \- com.amazonaws:aws-java-sdk-xray:jar:1.11.398:compile
             \- (com.amazonaws:aws-java-sdk-core:jar:1.11.398:compile - omitted for conflict with 1.11.438)

1.11.438
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    +- com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile
    +- com.amazonaws:aws-java-sdk-lambda:jar:1.11.438:compile
    |  \- (com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile - omitted for duplicate)
    +- com.amazonaws:aws-java-sdk-s3:jar:1.11.438:compile
    |  +- com.amazonaws:aws-java-sdk-kms:jar:1.11.438:compile
    |  |  \- (com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile - omitted for duplicate)
    |  \- (com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile - omitted for duplicate)
    \- pl.chilldev.commons:commons-aws:jar:0.4.4:compile
       +- com.amazonaws:aws-java-sdk-sns:jar:1.11.438:compile
       |  \- (com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile - omitted for duplicate)
       \- com.amazonaws:aws-java-sdk-sqs:jar:1.11.438:compile
          \- (com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile - omitted for duplicate)

com.amazonaws:aws-lambda-java-core

[Error]
1.1.0
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.sunrun:cfn-response:jar:1.1.0:compile
       \- (com.amazonaws:aws-lambda-java-core:jar:1.1.0:compile - omitted for conflict with 1.2.0)

1.2.0
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    +- com.amazonaws:aws-lambda-java-core:jar:1.2.0:compile
    +- io.symphonia:lambda-logging:jar:1.0.3:compile
    |  \- (com.amazonaws:aws-lambda-java-core:jar:1.2.0:compile - omitted for duplicate)
    \- pl.chilldev.commons:commons-aws:jar:0.4.4:compile
       \- (com.amazonaws:aws-lambda-java-core:jar:1.2.0:compile - omitted for duplicate)

com.amazonaws:jmespath-java

[Error]
1.11.398
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.amazonaws:aws-xray-recorder-sdk-aws-sdk:jar:2.0.1:compile
       \- com.amazonaws:aws-xray-recorder-sdk-core:jar:2.0.1:compile
          \- com.amazonaws:aws-java-sdk-xray:jar:1.11.398:compile
             \- (com.amazonaws:jmespath-java:jar:1.11.398:compile - omitted for conflict with 1.11.438)

1.11.438
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    +- com.amazonaws:aws-java-sdk-lambda:jar:1.11.438:compile
    |  \- com.amazonaws:jmespath-java:jar:1.11.438:compile
    +- com.amazonaws:aws-java-sdk-s3:jar:1.11.438:compile
    |  +- com.amazonaws:aws-java-sdk-kms:jar:1.11.438:compile
    |  |  \- (com.amazonaws:jmespath-java:jar:1.11.438:compile - omitted for duplicate)
    |  \- (com.amazonaws:jmespath-java:jar:1.11.438:compile - omitted for duplicate)
    \- pl.chilldev.commons:commons-aws:jar:0.4.4:compile
       +- com.amazonaws:aws-java-sdk-sns:jar:1.11.438:compile
       |  \- (com.amazonaws:jmespath-java:jar:1.11.438:compile - omitted for duplicate)
       \- com.amazonaws:aws-java-sdk-sqs:jar:1.11.438:compile
          \- (com.amazonaws:jmespath-java:jar:1.11.438:compile - omitted for duplicate)

com.fasterxml.jackson.core:jackson-core

[Error]
2.6.7
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile
       \- com.fasterxml.jackson.dataformat:jackson-dataformat-cbor:jar:2.6.7:compile
          \- (com.fasterxml.jackson.core:jackson-core:jar:2.6.7:compile - omitted for conflict with 2.9.7)

2.9.7
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    +- pl.chilldev.lambda:lambda-json:jar:0.0.2:compile
    |  \- com.fasterxml.jackson.datatype:jackson-datatype-jsr310:jar:2.9.7:compile
    |     \- (com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile - omitted for duplicate)
    +- com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile
    +- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile
    |  \- (com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile - omitted for duplicate)
    \- pl.chilldev.commons:commons-aws:jar:0.4.4:compile
       \- (com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile - omitted for duplicate)

com.fasterxml.jackson.core:jackson-databind

[Error]
2.6.7.1
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    +- com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile
    |  \- (com.fasterxml.jackson.core:jackson-databind:jar:2.6.7.1:compile - omitted for conflict with 2.9.7)
    \- com.amazonaws:aws-java-sdk-lambda:jar:1.11.438:compile
       \- com.amazonaws:jmespath-java:jar:1.11.438:compile
          \- (com.fasterxml.jackson.core:jackson-databind:jar:2.6.7.1:compile - omitted for conflict with 2.9.7)

2.7.3
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.sunrun:cfn-response:jar:1.1.0:compile
       \- (com.fasterxml.jackson.core:jackson-databind:jar:2.7.3:compile - omitted for conflict with 2.9.7)

2.9.7
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    +- pl.chilldev.lambda:lambda-json:jar:0.0.2:compile
    |  +- (com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile - omitted for duplicate)
    |  \- com.fasterxml.jackson.datatype:jackson-datatype-jsr310:jar:2.9.7:compile
    |     \- (com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile - omitted for duplicate)
    +- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile
    \- pl.chilldev.commons:commons-aws:jar:0.4.4:compile
       \- (com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile - omitted for duplicate)

com.google.code.findbugs:jsr305

[Error]
3.0.1
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.sunrun:cfn-response:jar:1.1.0:compile
       \- com.google.code.findbugs:jsr305:jar:3.0.1:compile

3.0.2
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.amazonaws:aws-xray-recorder-sdk-aws-sdk:jar:2.0.1:compile
       \- com.amazonaws:aws-xray-recorder-sdk-core:jar:2.0.1:compile
          \- com.google.guava:guava:jar:25.1-jre:compile
             \- (com.google.code.findbugs:jsr305:jar:3.0.2:compile - omitted for conflict with 3.0.1)

com.sunrun:cfn-response

[Error]
1.0.2
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- pl.chilldev.commons:commons-aws:jar:0.4.4:compile
       \- (com.sunrun:cfn-response:jar:1.0.2:compile - omitted for conflict with 1.1.0)

1.1.0
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.sunrun:cfn-response:jar:1.1.0:compile

commons-logging:commons-logging

[Error]
1.1.3
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile
       \- commons-logging:commons-logging:jar:1.1.3:compile

1.2
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile
       \- org.apache.httpcomponents:httpclient:jar:4.5.5:compile
          \- (commons-logging:commons-logging:jar:1.2:compile - omitted for conflict with 1.1.3)

joda-time:joda-time

[Error]
2.6
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- pl.chilldev.commons:commons-aws:jar:0.4.4:compile
       \- com.amazonaws:aws-lambda-java-events:jar:2.2.2:compile
          \- (joda-time:joda-time:jar:2.6:compile - omitted for conflict with 2.8.1)

2.8.1
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile
       \- joda-time:joda-time:jar:2.8.1:compile

org.apache.httpcomponents:httpclient

[Error]
4.5.2
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.sunrun:cfn-response:jar:1.1.0:compile
       \- (org.apache.httpcomponents:httpclient:jar:4.5.2:compile - omitted for conflict with 4.5.5)

4.5.5
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.amazonaws:aws-java-sdk-core:jar:1.11.438:compile
       \- org.apache.httpcomponents:httpclient:jar:4.5.5:compile

org.junit.jupiter:junit-jupiter-api

[Error]
5.1.1
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- org.mockito:mockito-junit-jupiter:jar:2.23.0:test
       \- (org.junit.jupiter:junit-jupiter-api:jar:5.1.1:test - omitted for conflict with 5.3.1)

  2. pl.chilldev.lambda:lambda-json:jar:0.0.2
    \- org.mockito:mockito-junit-jupiter:jar:2.23.0:test
       \- (org.junit.jupiter:junit-jupiter-api:jar:5.1.1:test - omitted for conflict with 5.3.1)

  3. pl.chilldev.lambda:lambda:pom:0.0.2
    \- org.mockito:mockito-junit-jupiter:jar:2.23.0:test
       \- (org.junit.jupiter:junit-jupiter-api:jar:5.1.1:test - omitted for conflict with 5.3.1)

5.3.1
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    +- org.junit.jupiter:junit-jupiter-api:jar:5.3.1:test
    \- org.junit.jupiter:junit-jupiter-engine:jar:5.3.1:test
       \- (org.junit.jupiter:junit-jupiter-api:jar:5.3.1:test - omitted for duplicate)

  2. pl.chilldev.lambda:lambda-json:jar:0.0.2
    +- org.junit.jupiter:junit-jupiter-api:jar:5.3.1:test
    \- org.junit.jupiter:junit-jupiter-engine:jar:5.3.1:test
       \- (org.junit.jupiter:junit-jupiter-api:jar:5.3.1:test - omitted for duplicate)

  3. pl.chilldev.lambda:lambda:pom:0.0.2
    +- org.junit.jupiter:junit-jupiter-api:jar:5.3.1:test
    \- org.junit.jupiter:junit-jupiter-engine:jar:5.3.1:test
       \- (org.junit.jupiter:junit-jupiter-api:jar:5.3.1:test - omitted for duplicate)

org.slf4j:slf4j-api

[Error]
1.7.19
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- com.sunrun:cfn-response:jar:1.1.0:compile
       \- (org.slf4j:slf4j-api:jar:1.7.19:compile - omitted for conflict with 1.7.25)

1.7.25
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    +- io.symphonia:lambda-logging:jar:1.0.3:compile
    |  +- org.slf4j:log4j-over-slf4j:jar:1.7.25:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.7.25:compile - omitted for conflict with 1.7.19)
    |  \- ch.qos.logback:logback-classic:jar:1.2.3:compile
    |     \- (org.slf4j:slf4j-api:jar:1.7.25:compile - omitted for conflict with 1.7.19)
    +- org.slf4j:slf4j-api:jar:1.7.25:compile
    \- pl.chilldev.commons:commons-aws:jar:0.4.4:compile
       \- (org.slf4j:slf4j-api:jar:1.7.25:compile - omitted for duplicate)

org.springframework:spring-core

[Error]
5.1.1.RELEASE
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- org.springframework.security:spring-security-test:jar:5.1.1.RELEASE:test
       +- org.springframework.security:spring-security-core:jar:5.1.1.RELEASE:test
       |  +- org.springframework:spring-aop:jar:5.1.1.RELEASE:test
       |  |  \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  +- org.springframework:spring-beans:jar:5.1.1.RELEASE:test
       |  |  \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  +- org.springframework:spring-context:jar:5.1.1.RELEASE:test
       |  |  \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  +- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  \- org.springframework:spring-expression:jar:5.1.1.RELEASE:test
       |     \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       +- org.springframework.security:spring-security-web:jar:5.1.1.RELEASE:test
       |  +- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  \- org.springframework:spring-web:jar:5.1.1.RELEASE:test
       |     \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)

  2. pl.chilldev.lambda:lambda-json:jar:0.0.2
    \- org.springframework.security:spring-security-test:jar:5.1.1.RELEASE:test
       +- org.springframework.security:spring-security-core:jar:5.1.1.RELEASE:test
       |  +- org.springframework:spring-aop:jar:5.1.1.RELEASE:test
       |  |  \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  +- org.springframework:spring-beans:jar:5.1.1.RELEASE:test
       |  |  \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  +- org.springframework:spring-context:jar:5.1.1.RELEASE:test
       |  |  \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  +- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  \- org.springframework:spring-expression:jar:5.1.1.RELEASE:test
       |     \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       +- org.springframework.security:spring-security-web:jar:5.1.1.RELEASE:test
       |  +- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  \- org.springframework:spring-web:jar:5.1.1.RELEASE:test
       |     \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)

  3. pl.chilldev.lambda:lambda:pom:0.0.2
    \- org.springframework.security:spring-security-test:jar:5.1.1.RELEASE:test
       +- org.springframework.security:spring-security-core:jar:5.1.1.RELEASE:test
       |  +- org.springframework:spring-aop:jar:5.1.1.RELEASE:test
       |  |  \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  +- org.springframework:spring-beans:jar:5.1.1.RELEASE:test
       |  |  \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  +- org.springframework:spring-context:jar:5.1.1.RELEASE:test
       |  |  \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  +- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  \- org.springframework:spring-expression:jar:5.1.1.RELEASE:test
       |     \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       +- org.springframework.security:spring-security-web:jar:5.1.1.RELEASE:test
       |  +- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       |  \- org.springframework:spring-web:jar:5.1.1.RELEASE:test
       |     \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)
       \- (org.springframework:spring-core:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)

5.1.2.RELEASE
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- org.springframework:spring-test:jar:5.1.2.RELEASE:test
       \- org.springframework:spring-core:jar:5.1.2.RELEASE:test

  2. pl.chilldev.lambda:lambda-json:jar:0.0.2
    \- org.springframework:spring-test:jar:5.1.2.RELEASE:test
       \- org.springframework:spring-core:jar:5.1.2.RELEASE:test

  3. pl.chilldev.lambda:lambda:pom:0.0.2
    \- org.springframework:spring-test:jar:5.1.2.RELEASE:test
       \- org.springframework:spring-core:jar:5.1.2.RELEASE:test

org.springframework:spring-test

[Error]
5.1.1.RELEASE
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- org.springframework.security:spring-security-test:jar:5.1.1.RELEASE:test
       \- (org.springframework:spring-test:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)

  2. pl.chilldev.lambda:lambda-json:jar:0.0.2
    \- org.springframework.security:spring-security-test:jar:5.1.1.RELEASE:test
       \- (org.springframework:spring-test:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)

  3. pl.chilldev.lambda:lambda:pom:0.0.2
    \- org.springframework.security:spring-security-test:jar:5.1.1.RELEASE:test
       \- (org.springframework:spring-test:jar:5.1.1.RELEASE:test - omitted for conflict with 5.1.2.RELEASE)

5.1.2.RELEASE
  1. pl.chilldev.lambda:lambda-edgedeploy:jar:0.0.2
    \- org.springframework:spring-test:jar:5.1.2.RELEASE:test

  2. pl.chilldev.lambda:lambda-json:jar:0.0.2
    \- org.springframework:spring-test:jar:5.1.2.RELEASE:test

  3. pl.chilldev.lambda:lambda:pom:0.0.2
    \- org.springframework:spring-test:jar:5.1.2.RELEASE:test